blob: e37ec1546c8b0efca4db053b5a70e5aad26a46b1 [file] [log] [blame]
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
DESCRIPTION="Python library providing a few tools handling SemVer in Python"
HOMEPAGE="
https://github.com/rbarrois/python-semanticversion/
https://pypi.org/project/semantic-version/
"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme
distutils_enable_tests pytest
python_test() {
epytest -p no:django
}