blob: 0a05a042a3183d784adbe8c1fea1f90fc60b8304 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml_core .gn"
DESCRIPTION="Chrome OS ML Core Feature Library"
PLATFORM_SUBDIR="ml_core"
inherit cros-workon platform
RDEPEND="
"
DEPEND="${RDEPEND}
"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
src_install() {
platform_src_install
dolib.so "${OUT}"/lib/libcros_ml_core.so
}
platform_pkg_test() {
platform test_all
}