blob: d3db280d045ffb74736b6162a016d89209b4fe79 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "2e036f417afe5d55dcbd138f7bfe2c98ab14403f" "8ca9c97a07408fdff5abf480fb1b2a15405b6bc0" "e92f2290c63a51a33949ed1a9610b7c26e83d813" "0c8e3de65339e7e6a1ffe16a54c7ae719bacc57c" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libhwsec libhwsec-foundation tpm_softclear_utils trunks .gn"
PLATFORM_SUBDIR="tpm_softclear_utils"
inherit cros-workon platform
DESCRIPTION="Utilities for soft-clearing TPM. This package resides in test images only."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/tpm_softclear_utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm tpm_dynamic tpm2"
REQUIRED_USE="
tpm_dynamic? ( tpm tpm2 )
!tpm_dynamic? ( ?? ( tpm tpm2 ) )
"
RDEPEND="
tpm2? (
chromeos-base/trunks:=
)
tpm? (
app-crypt/trousers:=
)
chromeos-base/libhwsec-foundation:=
"
DEPEND="${RDEPEND}
tpm2? (
chromeos-base/system_api:=
chromeos-base/trunks:=[test?]
)
"
src_install() {
# Installs the utilities executable.
insinto /usr/local/bin
doins "${OUT}/tpm_softclear"
chmod u+x "${D}/usr/local/bin/tpm_softclear"
}
platform_pkg_test() {
platform_test "run" "${OUT}/tpm_softclear_utils_testrunner"
}