blob: 0dd9334c58953c05eebeba2214a71261f87c45c2 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="af699a2a75b8905cb30cd7c6a0be61cdb1593d3e"
CROS_WORKON_TREE="85ff64bf9199aa5473db461312b3208004cbb7e0"
CROS_WORKON_PROJECT="chromiumos/platform/tast"
CROS_WORKON_LOCALNAME="platform/tast"
inherit cros-go cros-workon
CROS_GO_VERSION="${PF}"
CROS_GO_PACKAGES=(
"chromiumos/tast/framework/protocol/..."
)
CROS_GO_TEST=(
"${CROS_GO_PACKAGES[@]}"
)
DESCRIPTION="Provides go bindings to proto APIs for tast"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
DEPEND="
dev-go/protobuf-legacy-api
dev-go/text
"
RDEPEND=""
src_install() {
insinto /usr/lib/gopath/src/
cros-go_src_install
}