blob: 502c205525877d78c732357b26836f74070bee22 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "b996d22037bb49a510f4dbf3139a179f8727ed59" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk screen-capture-utils .gn"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
PLATFORM_SUBDIR="screen-capture-utils"
inherit cros-workon platform
DESCRIPTION="Utilities for screen capturing"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/screen-capture-utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Mark the old screenshot package as blocker so it gets automatically removed in
# incremental builds.
RDEPEND="
!chromeos-base/screenshot
media-libs/libpng:0=
media-libs/minigbm:=
net-libs/libvncserver
x11-libs/libdrm:=
virtual/opengles"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers"
src_install() {
platform_install
# Component: ARC++ > Eng Velocity.
local fuzzer_component_id="515942"
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/screen-capture_png_fuzzer \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform test_all
}