blob: 68d0c23f0962000b8af6bd0170f18ba9887086ff [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("dbb1136242ba822d539eaf11493f3b68815adb7f" "3abfd77090d24ca8d2d7260d6ba6aaec2e4c35ae")
CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "86f25a69ccb900fd0f5da1a8861df68696c36330")
inherit cros-constants
CROS_WORKON_LOCALNAME=(
"platform2"
"platform/pinweaver"
)
CROS_WORKON_PROJECT=(
"chromiumos/platform2"
"chromiumos/platform/pinweaver"
)
CROS_WORKON_OPTIONAL_CHECKOUT=(
"true"
"true"
)
CROS_WORKON_DESTDIR=(
"${S}/platform2"
"${S}/platform2/pinweaver"
)
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE=(
"common-mk .gn"
""
)
PLATFORM_SUBDIR="pinweaver"
inherit cros-workon platform
DESCRIPTION="PinWeaver code that can be used across implementation platforms."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/pinweaver/+/main/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
src_install() {
dolib.a "${OUT}"/libpinweaver.a
insinto /usr/include/pinweaver
doins eal/tpm_storage/pinweaver_eal_types.h
doins pinweaver.h
doins pinweaver_eal.h
doins pinweaver_types.h
}