blob: 95c8864b98a3d614f79ac9c19e2671e0284a784b [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml_benchmark .gn"
DESCRIPTION="Chrome OS ML Benchmarking Suite"
PLATFORM_SUBDIR="ml_benchmark"
inherit cros-workon platform
# chromeos-base/ml_benchmark blocked due to package rename
RDEPEND="
!chromeos-base/ml_benchmark
vulkan? ( media-libs/clvk )
"
DEPEND="${RDEPEND}
dev-libs/protobuf:=
"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="vulkan"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}