blob: cfa09f21be3a0bf04875b077f85ef6cd12c24f59 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "363badc7f07136727d95cdd25b229e9282328f00" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml_benchmark .gn"
DESCRIPTION="Chrome OS ML Benchmarking Suite"
PLATFORM_SUBDIR="ml_benchmark"
inherit cros-workon platform
# chromeos-base/ml_benchmark blocked due to package rename
RDEPEND="
!chromeos-base/ml_benchmark
vulkan? ( media-libs/clvk )
"
DEPEND="${RDEPEND}
dev-libs/protobuf:=
"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="vulkan"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}