blob: c639cb5fbda690871936f5d130f768bac9fe6072 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=6
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk metrics mist .gn"
PLATFORM_SUBDIR="mist"
inherit cros-workon platform udev
DESCRIPTION="Chromium OS Modem Interface Switching Tool"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/mist/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="~*"
IUSE=""
RDEPEND="
chromeos-base/libbrillo:=[udev]
>=chromeos-base/metrics-0.0.1-r3152
dev-libs/protobuf:=
net-dialup/ppp
virtual/libusb:1
virtual/udev
"
DEPEND="${RDEPEND}"
platform_pkg_test() {
platform test_all
}
src_install() {
platform_install
udev_dorules 51-mist.rules
}