blob: ecfe16e1e13d4ccd53771a3515288fcb512bfc1f [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libipp .gn"
PLATFORM_SUBDIR="libipp"
inherit cros-workon platform
DESCRIPTION="The library for building and parsing IPP (Internet Printing Protocol) frames."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libipp/"
LICENSE="BSD-Google"
KEYWORDS="~*"
src_install() {
platform_install
# Install fuzzer
local fuzzer_component_id="167231"
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/libipp_fuzzer \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform test_all
}