blob: a3a56a4e5ca84d9648b12b1eb61adb6811396c9f [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_USE_VCSID="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libcrossystem .gn"
PLATFORM_SUBDIR="libcrossystem"
inherit cros-workon platform
DESCRIPTION="Library to get Chromium OS system properties"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libcrossystem"
LICENSE="BSD-Google"
KEYWORDS="~*"
COMMON_DEPEND=""
RDEPEND="
${COMMON_DEPEND}
"
DEPEND="
${COMMON_DEPEND}
chromeos-base/vboot_reference:=
"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}