blob: 0edbfe9ac31b078ed77ecb25a7e06085f0636d4b [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "bc5f4dc1eac5097a6d543202f4a5a5a4460f724b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk imageloader .gn"
PLATFORM_SUBDIR="imageloader/client"
inherit cros-workon platform
DESCRIPTION="ImageLoader DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/imageloader/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="cros_host"
# D-Bus proxies generated by this client library depend on the code generator
# itself (chromeos-dbus-bindings) and produce header files that rely on
# libbrillo library.
DEPEND="
cros_host? ( chromeos-base/chromeos-dbus-bindings:= )
"
RDEPEND="chromeos-base/imageloader"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "imageloader"
}