blob: ee8962e790e72be858ca91ffc23d9bc6239db62a [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "ddbdbd7f7519a0d8da3e33b0eaf9c5a88dc3084e" "60fa47aebd6ebfb702012849bd560717fceddcd4" "509fcdecd3a70e50e5aa4e48d65de2dbd6decdb9")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE=".gn hps common-mk metrics"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="hps"
inherit cros-workon platform udev user
DESCRIPTION="Chrome OS HPS daemon."
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
chromeos-base/metrics:=
virtual/libusb:1
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
"
pkg_preinst() {
enewuser "hpsd"
enewgroup "hpsd"
}
src_install() {
platform_src_install
dosbin "${OUT}"/hpsd
# Install upstart configuration.
insinto /etc/init
doins daemon/init/hpsd.conf
insinto /etc/dbus-1/system.d
doins daemon/dbus/org.chromium.Hps.conf
exeinto "$(get_udevdir)"
doexe udev/*.sh
udev_dorules udev/*.rules
}
platform_pkg_test() {
local tests=(
dev_test
hps_test
hps_metrics_test
hps_daemon_test
hps_filter_test
)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test run "${OUT}/${test_bin}"
done
}