blob: b3cc7263a0e7a9a7d93de5cc39b41704f958622d [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5157666de939bc298ac12925891a55062f92e262"
CROS_WORKON_TREE="973913527c97518feffdeea7eafd58e0e4d9955f"
CROS_WORKON_PROJECT="chromiumos/platform/factory_installer"
CROS_WORKON_LOCALNAME="platform/factory_installer"
CROS_RUST_CRATE_NAME="factory_ufs"
CROS_RUST_SUBDIR="rust"
inherit cros-workon cros-rust
DESCRIPTION="A binary for UFS provisioning written in Rust"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/factory_installer/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
DEPEND="chromeos-base/factory_rust"
RDEPEND="
sys-apps/ufs-utils
"
src_test() {
cros-rust_src_test --no-default-features --features="factory-ufs" \
--lib
}
src_compile() {
cros-rust_src_compile --no-default-features --features="factory-ufs" \
--bin="factory_ufs"
}
src_install() {
dosbin "$(cros-rust_get_build_dir)/factory_ufs"
}