blob: e56100842f87f32ab59fa317379de021c2e1c785 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-config libec runtime_probe .gn"
PLATFORM_SUBDIR="runtime_probe/factory_runtime_probe"
inherit cros-workon cros-unibuild platform
DESCRIPTION="Device component probe tool **for factory environment**."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/runtime_probe/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="cros-debug"
# TODO(yhong): Extract common parts with runtime_probe-9999.ebuild to a shared
# eclass.
COMMON_DEPEND="
chromeos-base/chromeos-config-tools:=
"
RDEPEND="
${COMMON_DEPEND}
chromeos-base/ec-utils
"
# Add vboot_reference as build time dependency to read cros_debug status
DEPEND="${COMMON_DEPEND}
chromeos-base/debugd-client:=
chromeos-base/libec:=
chromeos-base/shill-client:=
chromeos-base/system_api:=
chromeos-base/vboot_reference:=
media-libs/minigbm:=
"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}