blob: 3aba2a2a0cf5511436b84a8a4540910a94c421e2 [file] [log] [blame]
# Copyright (c) 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="a1298a3f48a90fb72cefbd674ebb0fcef18c214f"
CROS_WORKON_TREE="3ebd1bcdfcefa8558aaa5c66da3bd9ccf4f50405"
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME="platform/dev"
CROS_WORKON_OUTOFTREE_BUILD="1"
inherit cros-workon
DESCRIPTION="Server to cache Chromium OS build artifacts from Google Storage."
HOMEPAGE="http://dev.chromium.org/chromium-os/how-tos-and-troubleshooting/using-the-dev-server"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
dev-lang/python
dev-python/protobuf-python
dev-python/cherrypy
net-misc/gsutil
!<chromeos-base/cros-devutils-1
"
DEPEND="
dev-python/psutil
"
src_install() {
emake install DESTDIR="${D}"
}
src_test() {
# Run the unit tests.
./run_unittests || die
}