blob: 54001d539575fe5f999ab5d54575ad90bc905d23 [file] [log] [blame]
# Copyright 2022 The ChromiumOS Authors.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI="7"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk chargesplash .gn"
PLATFORM_SUBDIR="chargesplash"
inherit cros-workon platform
DESCRIPTION="Frecon-based charging indicator"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/chargesplash"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
DEPEND="
chromeos-base/libec:=
"
RDEPEND="
${DEPEND}
sys-apps/frecon
"
src_install() {
dobin "${OUT}/chargesplash"
}
platform_pkg_test() {
platform test_all
}