blob: dd315ea76cc1b23d03b9a40b230c269e30dd5c49 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="dbb1136242ba822d539eaf11493f3b68815adb7f"
CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "83ca22e88798e1cc90cb146bff627f7dca4893bc" "8ef7c6aabe0a8edeff8f6030f7c1b79ab3e32522" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk bootid-logger croslog .gn"
PLATFORM_SUBDIR="bootid-logger"
inherit cros-workon platform
DESCRIPTION="Program to record the current boot ID to the log"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/bootid-logger"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
RDEPEND=">=chromeos-base/croslog-0.0.1-r45"
DEPEND="${RDEPEND}"
src_install() {
platform_install
insinto /etc/init
doins log-bootid-on-boot.conf
local fuzzer_component_id="1029735"
platform_fuzzer_install "${S}"/../croslog/OWNERS "${OUT}"/bootid_logger_fuzzer \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform test_all
}