blob: 6ec82db5f23b5b257de5e5e68450ce665681e6fe [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_USE_VCSID="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk biod .gn"
PLATFORM_SUBDIR="biod/biod_proxy"
inherit cros-workon platform
DESCRIPTION="DBus Proxy Library for Biometrics Daemon for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/biod/README.md"
LICENSE="BSD-Google"
KEYWORDS="~*"
RDEPEND=""
DEPEND="
chromeos-base/libbrillo:=
chromeos-base/system_api:=
"
src_install() {
platform_install
}
platform_pkg_test() {
platform test_all
}