blob: 0d863aaff23ef4025a408b5b691f03378bb57c23 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="6d56a91e36c7415ef754171fe84cab5df045334c"
CROS_WORKON_TREE="0afe9e545add6bbfe1e753734251c983a93fad69"
PYTHON_COMPAT=( python3_{6..9} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon autotest libchrome cros-sanitizers python-any-r1
DESCRIPTION="Security autotests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
# Enable autotest by default.
IUSE="+autotest -chromeless_tests -chromeless_tty containers +seccomp selinux"
RDEPEND="
!<chromeos-base/autotest-tests-0.0.3
"
DEPEND="${RDEPEND}"
IUSE_TESTS="
+tests_security_NosymfollowMountOption
"
IUSE="${IUSE} ${IUSE_TESTS}"
AUTOTEST_FILE_MASK="*.a *.tar.bz2 *.tbz2 *.tgz *.tar.gz"
cros_pre_src_configure_use_sanitizers() {
sanitizers-setup-env
}