| # Copyright 2017 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75" |
| CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "92e3d0aa6c1005f33e6a3ca09fbb2a775cf67d9f" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb") |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk arc/mount-passthrough .gn" |
| |
| PLATFORM_SUBDIR="arc/mount-passthrough" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Mounts the specified directory with different owner UID and GID" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/mount-passthrough" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| |
| COMMON_DEPEND="sys-fs/fuse:= |
| sys-libs/libcap:=" |
| RDEPEND="${COMMON_DEPEND}" |
| DEPEND="${COMMON_DEPEND}" |
| |
| src_install() { |
| dobin "${OUT}"/mount-passthrough |
| dobin mount-passthrough-jailed |
| dobin mount-passthrough-jailed-media |
| dobin mount-passthrough-jailed-play |
| |
| insinto /usr/share/arc |
| doins mount-passthrough-jailed-utils.sh |
| } |