blob: cb2727718b5c1c48707aadbd8ab9d555b878b804 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_RUST_REMOVE_DEV_DEPS=1
inherit cros-rust
DESCRIPTION='Extra iterator adaptors, iterator methods, free functions, and macros.'
HOMEPAGE='https://crates.io/crates/itertools'
SRC_URI="https://crates.io/api/v1/crates/${PN}/${PV}/download -> ${P}.crate"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="${PV}/${PR}"
KEYWORDS="*"
DEPEND="
=dev-rust/either-1*:=
"
RDEPEND="${DEPEND}"
# This file was automatically generated by cargo2ebuild.py
IUSE="test"
TEST_DEPS="
test? (
=dev-rust/permutohedron-0.2*:=
=dev-rust/quickcheck-0.7*:=
=dev-rust/rand-0.6*:=
)
"
DEPEND+="${TEST_DEPS}"
RDEPEND+="${TEST_DEPS}"
src_prepare() {
if use test; then
CROS_RUST_REMOVE_DEV_DEPS=0
fi
cros-rust_src_prepare
}