blob: 78dde309af27b637d7b5dcf00460a0b2ce1fed31 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b1fb85673bd75c54dae214fc3d7764672916819d"
CROS_WORKON_TREE="4ddc1331cc37b407523e4c42a01d9d6cdbe6d9eb"
CROS_WORKON_PROJECT="chromiumos/platform/tast"
CROS_WORKON_LOCALNAME="platform/tast"
inherit cros-go cros-workon
CROS_GO_VERSION="${PF}"
CROS_GO_PACKAGES=(
"chromiumos/tast/framework/protocol/..."
)
CROS_GO_TEST=(
"${CROS_GO_PACKAGES[@]}"
)
DESCRIPTION="Provides go bindings to proto APIs for tast"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
DEPEND=""
RDEPEND=""
src_install() {
insinto /usr/lib/gopath/src/
cros-go_src_install
}