blob: fd634b851160f57b29a4bbaec725676c9e7c4672 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5bbbe52a139486abcbd802b9bd3f6763dac479b3"
CROS_WORKON_TREE=("ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722" "26b91e41e669cca59d25dedeb6fb18c470d60c4b" "6f00dc3af5877e8ec4a9732ea54508e2a9a280d2" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk libcontainer run_oci .gn"
PLATFORM_SUBDIR="run_oci"
inherit cros-workon libchrome platform
DESCRIPTION="Utility for running OCI-compatible containers"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
COMMON_DEPEND="
chromeos-base/libcontainer:=
chromeos-base/minijail:=
sys-apps/util-linux:=
sys-libs/libcap:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
src_install() {
cd "${OUT}"
dobin run_oci
}
platform_pkg_test() {
local tests=(
container_config_parser_test
run_oci_test
)
local test_bin
for test_bin in "${tests[@]}"; do
# platform_test takes care of setting up your test environment
platform_test "run" "${OUT}/${test_bin}"
done
}