blob: 4d377d9aaedc67697655ffa5efa9069652a07a84 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk ml .gn"
PLATFORM_SUBDIR="ml/ml-client"
inherit cros-workon platform
DESCRIPTION="ML Service D-Bus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/main/ml/"
LICENSE="BSD-Google"
KEYWORDS="~*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install D-Bus client library.
platform_install_dbus_client_lib "ml"
}