blob: 80dea2c9b3eb5c832ee56835e802c1deaa388d58 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk diagnostics/mojo .gn"
PLATFORM_SUBDIR="diagnostics/mojo"
WANT_LIBBRILLO="no"
inherit cros-workon platform
DESCRIPTION="Chrome OS Mojo client for cros_healthd"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/diagnostics/mojo"
LICENSE="BSD-Google"
KEYWORDS="~*"
src_install() {
# Install package config.
insinto /usr/"$(get_libdir)"/pkgconfig
doins cros_healthd-client.pc
# Install mojom files.
insinto /usr/src/cros_healthd-client/mojom/
doins "${S}"/*.mojom
# Install mojom modules.
insinto /usr/src/cros_healthd-client/modules/
doins "${OUT}"/gen/include/mojo/*module
# Install C++ headers.
insinto /usr/include/cros_healthd-client/mojo
doins "${OUT}"/gen/include/mojo/*.h
# Install libraries linked by the C++ headers.
dolib.a "${OUT}"/*.a
}