blob: 524ff150cc016282250d23da5a9afab5779d9486 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="1f9d9f4574a9655d844c7ef46f138da7228a93a9"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "e5bab9aeb635f426a5f77597edb46ad386ad0f7c" "080361d5d45e74e7927e56bab774531748d1a569" "8aea57128c1adc8ea0b845047ce01733cecaf5c1" "a4c500ab9b3c0bc4232aa527a6cbd18f786338a4" "a625767bb59509159091f2ab0b71f8b9b4b2e353")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/include camera/gpu camera/common common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/gpu/tests"
inherit cros-workon platform
DESCRIPTION="Chrome OS camera GPU-related tests"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="virtual/pkgconfig"
RDEPEND="
chromeos-base/cros-camera-android-deps:=
chromeos-base/cros-camera-libs:=
dev-cpp/gtest:=
virtual/opengles:=
"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers:=
"
src_configure() {
cros_optimize_package_for_speed
platform_src_configure
}
src_install() {
dobin "${OUT}"/image_processor_test
platform_src_install
}