blob: f1be5dcbfcf385f99ced2945303102c8f1279c10 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="05b5852bbf00f85e097be08bf5344d2f735171d7"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "f3c3e81430aaee7361f2701b718ba3af9f201a7e" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk typecd .gn"
PLATFORM_SUBDIR="typecd"
inherit cros-workon platform user
DESCRIPTION="Chrome OS USB Type C daemon"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/typecd/"
LICENSE="BSD-Google"
SLOT=0
KEYWORDS="*"
src_install() {
dobin "${OUT}"/typecd
}
pkg_preinst() {
enewuser typecd
enewgroup typecd
}
platform_pkg_test() {
platform_test "run" "${OUT}/typecd_testrunner"
}