blob: 09dbfdb8eef2c3d3a56f586e293cb8171f13b6de [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="60ac81314efc8b9afa57bfed98402b9250a51128"
CROS_WORKON_TREE="72d10c78adcc6d635f7cb9fff4b87ac70c16a7b2"
PYTHON_COMPAT=( python2_7 python{3_6,3_7,3_8} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit autotest cros-workon flag-o-matic python-any-r1
DESCRIPTION="Public ARC autotests"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
RDEPEND="
dev-python/pyxattr
chromeos-base/chromeos-chrome
chromeos-base/autotest-chrome
chromeos-base/telemetry
"
DEPEND="${RDEPEND}"
IUSE="
+autotest
"
src_prepare() {
# Telemetry tests require the path to telemetry source to exist in order to
# build. Copy the telemetry source to a temporary directory that is writable,
# so that file removals in Telemetry source can be performed properly.
export TMP_DIR="$(mktemp -d)"
cp -r "${SYSROOT}/usr/local/telemetry" "${TMP_DIR}"
export PYTHONPATH="${TMP_DIR}/telemetry/src/third_party/catapult/telemetry"
autotest_src_prepare
}