blob: 050128855add1f0788b644c3203239f1092decbb [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="60ac81314efc8b9afa57bfed98402b9250a51128"
CROS_WORKON_TREE="72d10c78adcc6d635f7cb9fff4b87ac70c16a7b2"
PYTHON_COMPAT=( python2_7 python{3_6,3_7,3_8} )
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon autotest-deponly python-any-r1
DESCRIPTION="Autotest touchpad deps"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="*"
# Autotest enabled by default.
IUSE="+autotest"
AUTOTEST_DEPS_LIST="touchpad-tests"
AUTOTEST_CONFIG_LIST=
AUTOTEST_PROFILERS_LIST=
# NOTE: For deps, we need to keep *.a
AUTOTEST_FILE_MASK="*.tar.bz2 *.tbz2 *.tgz *.tar.gz"
# deps/touchpad-tests
RDEPEND="
x11-drivers/touchpad-tests
chromeos-base/touch_firmware_test
chromeos-base/mttools
"
DEPEND="${RDEPEND}"