blob: 5ab6d23949c1999b168b5c4b10a17dc21d932f61 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="c142078820d0707858873cedb290a78d36f531af"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "e5d3b93967ab0491498bc90862f9bee73883fea8" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk secure_erase_file .gn"
PLATFORM_SUBDIR="secure_erase_file"
inherit cros-workon platform
DESCRIPTION="Secure file erasure for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/secure_erase_file/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
DEPEND="
"
RDEPEND="
"
src_install() {
dobin "${OUT}/secure_erase_file"
dolib.so "${OUT}/lib/libsecure_erase_file.so"
insinto /usr/include/chromeos/secure_erase_file
doins secure_erase_file.h
}