blob: c69668b84bce4c850ae8b44810839f30aef7706e [file] [log] [blame]
# Copyright (c) 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="4c9b0bff59adfa276da2c9daa2b3143ea8b6b09c"
CROS_WORKON_TREE="d02bd2d710b9a2ab06a9d9746e9b146bb911f1fe"
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME="platform/dev"
CROS_WORKON_OUTOFTREE_BUILD="1"
inherit cros-workon
DESCRIPTION="Server to cache Chromium OS build artifacts from Google Storage."
HOMEPAGE="http://dev.chromium.org/chromium-os/how-tos-and-troubleshooting/using-the-dev-server"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
dev-lang/python
dev-python/protobuf-python
dev-python/cherrypy
net-misc/gsutil
!<chromeos-base/cros-devutils-1
"
DEPEND="
dev-python/psutil
"
src_install() {
emake install DESTDIR="${D}"
}
src_test() {
# Run the unit tests.
./run_unittests || die
}