blob: a0b137b9acb1fe1a91c44bba05786ada230d603c [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="be3443cd10cdfb85ddb5df77b377d7f6b34e311a"
CROS_WORKON_TREE="ba168cd4a4877aafcfca4aa5f9e548d6416ac96e"
CROS_WORKON_LOCALNAME="../platform/crosvm"
CROS_WORKON_PROJECT="chromiumos/platform/crosvm"
# We don't use CROS_WORKON_OUTOFTREE_BUILD here since audio_streams/Cargo.toml
# is using "provided by ebuild" macro which supported by cros-rust
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="audio_streams"
# Pupr handles uprevs of crosvm.
CROS_WORKON_MANUAL_UPREV="1"
inherit cros-workon cros-rust
DESCRIPTION="Crate provides a basic interface for playing audio."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/adhd/+/HEAD/audio_streams"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test"
DEPEND="
>=dev-rust/async-trait-0.1.36:= <dev-rust/async-trait-0.2
dev-rust/cros_async:=
=dev-rust/remain-0.2*:=
dev-rust/sync:=
dev-rust/sys_util:=
>=dev-rust/thiserror-1.0.20:= <dev-rust/thiserror-2.0
"
# (crbug.com/1182669): build-time only deps need to be in RDEPEND so they are pulled in when
# installing binpkgs since the full source tree is required to use the crate.
RDEPEND="${DEPEND}
!<=media-sound/audio_streams-0.1.0-r7
"