blob: f9360153f8b1cef74bee3a87a61e6ea523e2f4b3 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b7ed0ed288d39556e6141108005d048b913afed7"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "a9db923ed9d7e66024405ab4fdb8bbe178930040" "32ac98629dfba863322d9dc20a553d071bb70df0" "21f96983b4c04d23267767a4f371212fe68039d9" "786825f5ecfe94fcf4d839470255111ca27b4d6f" "f4393b535673365e930c04efeab0ab4a23a5a8a0" "ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722" "77d69659cf481a4d0917b7c100630f3c969b5720")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# iioservice/ is included just to make sandbox happy when running `gn gen`.
CROS_WORKON_SUBTREE=".gn camera/build camera/features camera/include camera/gpu camera/common common-mk iioservice/libiioservice_ipc"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/features/hdrnet/tests"
inherit cros-workon platform
DESCRIPTION="Chrome OS camera HDRnet integration tests"
LICENSE="BSD-Google"
KEYWORDS="*"
# 'ipu6' and 'ipu6ep' are passed to and used in BUILD.gn files.
IUSE="ipu6 ipu6ep"
BDEPEND="virtual/pkgconfig"
RDEPEND="
chromeos-base/cros-camera-android-deps:=
chromeos-base/cros-camera-libs:=
dev-cpp/gtest:=
media-libs/cros-camera-libhdr:=
virtual/opengles:=
"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers:=
"
src_configure() {
cros_optimize_package_for_speed
platform_src_configure
}
src_install() {
dobin "${OUT}"/hdrnet_stream_manipulator_test
dobin "${OUT}"/hdrnet_processor_impl_test
platform_src_install
}