blob: 2d819d8e92f9834ec6c3487253f8684792e29771 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="745cdedb276031fbceedfb76854b10a234cab662"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "a9db923ed9d7e66024405ab4fdb8bbe178930040" "f4393b535673365e930c04efeab0ab4a23a5a8a0" "b859b43cd8fde226526c57956659101cf8b11b74" "21f96983b4c04d23267767a4f371212fe68039d9" "542b6a1b940801e08d9d1aa3ff2657d06dc80bfa" "3a8b816b9fdaca04ec76e8a8d97b206e139a9dfc" "ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/hal/usb camera/include camera/mojo chromeos-config common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/hal/usb"
inherit cros-camera cros-workon platform
DESCRIPTION="Chrome OS USB camera HAL v3."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
RDEPEND="
chromeos-base/cros-camera-android-deps
chromeos-base/cros-camera-libs
dev-libs/re2
media-libs/libsync
chromeos-base/chromeos-config-tools"
DEPEND="${RDEPEND}
media-libs/libyuv
virtual/pkgconfig"
src_install() {
platform_src_install
cros-camera_dohal "${OUT}/lib/libcamera_hal.so" usb.so
}
platform_pkg_test() {
local tests=(
image_processor_test
)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test run "${OUT}/${test_bin}"
done
}