blob: d56424bab03f6a4750824c538a080e174a41a2f1 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_RUST_REMOVE_DEV_DEPS=1
inherit cros-rust
DESCRIPTION='Low level access to Cortex-M processors'
HOMEPAGE='https://crates.io/crates/cortex-m'
SRC_URI="https://crates.io/api/v1/crates/${PN}/${PV}/download -> ${P}.crate"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="${PV}/${PR}"
KEYWORDS="*"
DEPEND="
>=dev-rust/aligned-0.3.1:= <dev-rust/aligned-0.4.0
=dev-rust/bare-metal-0.2*:=
>=dev-rust/bitfield-0.13.2:= <dev-rust/bitfield-0.14.0
=dev-rust/cortex-m-0.7*:=
=dev-rust/volatile-register-0.2*:=
"
RDEPEND="${DEPEND}"
# This file was automatically generated by cargo2ebuild.py
src_install() {
cros-rust_src_install
# Do not strip prebuilt .a files in the crate sources
# shellcheck disable=SC2154
dostrip -x "${CROS_RUST_REGISTRY_BASE}"
}