blob: f6ac579562cb39367c9b2e469e2a4cef89173b05 [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
inherit cros-constants
CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/modp_b64")
CROS_WORKON_LOCALNAME=("../platform2" "../third_party/modp_b64")
CROS_WORKON_PROJECT=("chromiumos/platform2" "aosp/platform/external/modp_b64")
CROS_WORKON_SUBTREE=("common-mk .gn" "")
CROS_WORKON_EGIT_BRANCH="master"
PLATFORM_SUBDIR="modp_b64"
WANT_LIBCHROME=no
inherit cros-fuzzer cros-sanitizers cros-workon platform
DESCRIPTION="Base64 encoder/decoder library."
HOMEPAGE="https://github.com/client9/stringencoders"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~*"
IUSE="fuzzer"
src_install() {
dolib.a "${OUT}"/libmodp_b64.a
insinto /usr/include
doins -r modp_b64
insinto "/usr/$(get_libdir)/pkgconfig"
doins "${OUT}/obj/modp_b64/libmodp_b64.pc"
local fuzzer_component_id="1034879"
fuzzer_install "${S}/OWNERS.fuzzer" "${OUT}"/modp_b64_decode_fuzzer \
--comp "${fuzzer_component_id}"
fuzzer_install "${S}/OWNERS.fuzzer" "${OUT}"/modp_b64_encode_fuzzer \
--comp "${fuzzer_component_id}"
}