blob: a1dd6b1279e2af8a5fe4bd967b8418e78ad7762a [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
# This ebuild is for running tast DLC test in the lab and local dev setup.
# For future DLC autotests, a new installation process needs to be re-designed.
EAPI=6
CROS_WORKON_COMMIT="d04bb7bd38db52b70d199a924301617947efe018"
CROS_WORKON_TREE="b68ce606576817036151d1802df806eb198f96ec"
PYTHON_COMPAT=( python2_7 python3_{6,7} )
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME="platform/dev"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="nebraska"
inherit cros-workon python-r1
DESCRIPTION="A set of utilities for updating Chrome OS."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
RDEPEND="!chromeos-base/gmerge"
# Add an empty src_compile() so we bypass compile stage.
src_compile() { :; }
src_install() {
into /usr/local
dobin nebraska/nebraska.py
insinto /etc/init
doins nebraska/nebraska.conf
}
src_test() {
# Run the unit tests.
python_test() {
"$PYTHON" nebraska/nebraska_unittest.py || die
}
python_foreach_impl python_test
}