blob: 1516e44677236f6e70d2c38f290843b149b6b2bf [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5bbbe52a139486abcbd802b9bd3f6763dac479b3"
CROS_WORKON_TREE=("ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722" "1a305e65cfaf27dd42734a37eda080d40b377d6c" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk secure_erase_file .gn"
PLATFORM_SUBDIR="secure_erase_file"
inherit cros-workon platform
DESCRIPTION="Secure file erasure for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/secure_erase_file/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
DEPEND="
"
RDEPEND="
"
src_install() {
dobin "${OUT}/secure_erase_file"
dolib.so "${OUT}/lib/libsecure_erase_file.so"
insinto /usr/include/chromeos/secure_erase_file
doins secure_erase_file.h
}