blob: 63160cf8d2ee5b3faec1e358c6f011cccb216f48 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5bbbe52a139486abcbd802b9bd3f6763dac479b3"
CROS_WORKON_TREE=("ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722" "5ac90bfc3e80b94b55eeda07469ee072224a0151" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_SUBTREE="common-mk fusebox .gn"
PLATFORM_SUBDIR="fusebox"
inherit cros-workon platform user
DESCRIPTION="FuseBox service"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/main/fusebox"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test"
COMMON_DEPEND="
dev-libs/protobuf:=
sys-apps/dbus:=
sys-fs/fuse:=
sys-libs/libcap:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
chromeos-base/system_api
"
src_install() {
dobin "${OUT}"/fusebox
}
platform_pkg_test() {
local tests=(fusebox_test)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test "run" "${OUT}/${test_bin}"
done
}