blob: f6198cc7f99a3b2f2bf1f65f2f23d0e19312a072 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk foomatic_shell .gn"
PLATFORM_SUBDIR="foomatic_shell"
inherit cros-workon platform
DESCRIPTION="Mini shell used by foomatic-rip to execute scripts in PPD files."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/foomatic_shell/"
LICENSE="BSD-Google"
KEYWORDS="~*"
src_install() {
dobin "${OUT}/foomatic_shell"
# Install fuzzer
local fuzzer_component_id="167231"
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/foomatic_shell_fuzzer \
--comp "${fuzzer_component_id}"
}
platform_pkg_test() {
platform_test "run" "${OUT}/foomatic_shell_test"
}