blob: 0a65cf5c75f97179249157674a89708dea839031 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5bbbe52a139486abcbd802b9bd3f6763dac479b3"
CROS_WORKON_TREE=("ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722" "d15456cdcdb891b358e4f18984bdbe147c6ba380" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk featured .gn"
PLATFORM_SUBDIR="featured"
inherit cros-workon platform user
DESCRIPTION="Chrome OS feature management service"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/featured/"
LICENSE="BSD-Google"
KEYWORDS="*"
DEPEND="
chromeos-base/system_api:=
sys-apps/dbus:="
src_install() {
into /
dosbin "${OUT}"/featured
# Install DBus configuration.
insinto /etc/dbus-1/system.d
doins share/org.chromium.featured.conf
insinto /etc/init
doins share/featured.conf share/platform-features.json
}