blob: fc5fec7a85d5164cc236064bba137dfa57c0e4d5 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5bbbe52a139486abcbd802b9bd3f6763dac479b3"
CROS_WORKON_TREE=("ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722" "3a8b816b9fdaca04ec76e8a8d97b206e139a9dfc" "c49e61abb0d60510e8ca41e657656cdd950c50e9" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-config runtime_probe .gn"
PLATFORM_SUBDIR="runtime_probe"
inherit cros-workon cros-unibuild platform
DESCRIPTION="Device component probe tool **for factory environment**."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/runtime_probe/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="cros-debug +factory_runtime_probe"
# TODO(yhong): Extract common parts with runtime_probe-9999.ebuild to a shared
# eclass.
COMMON_DEPEND="
chromeos-base/chromeos-config-tools:=
"
RDEPEND="
${COMMON_DEPEND}
chromeos-base/ec-utils
"
# Add vboot_reference as build time dependency to read cros_debug status
DEPEND="${COMMON_DEPEND}
chromeos-base/debugd-client:=
chromeos-base/shill-client:=
chromeos-base/system_api:=
chromeos-base/vboot_reference:=
"
pkg_setup() {
cros-workon_pkg_setup
# Assert that the package is not "directly" installed into Chrome OS
# images. We currently only anticipate that files introduced by this
# package being used as the source materials for other packages.
if [[ "$(cros_target)" != "board_sysroot" ]]; then
die "${PN} should never be installed into Chrome OS images directly."
fi
}
src_install() {
dobin "${OUT}/factory_runtime_probe"
dobin "${OUT}/factory_runtime_probe_installer"
}