blob: 9d395e000c0a0499b79990ef4c7a8fb7f0ff9f80 [file] [log] [blame]
# Copyright (c) 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the BSD license.
EAPI=7
CROS_WORKON_COMMIT="97e19f6c183413affb7dbef8b4265234b78f6365"
CROS_WORKON_TREE="5e05b63e4b72537a39603f4a9f5a68eebf845602"
CROS_WORKON_PROJECT="chromiumos/platform/touch_updater"
CROS_WORKON_LOCALNAME="touch_updater"
CROS_WORKON_SUBTREE="etphidiap"
CROS_WORKON_OUTOFTREE_BUILD=1
inherit cros-workon user
DESCRIPTION="Wrapper for etphidiap touch firmware updater."
HOMEPAGE="https://www.chromium.org/chromium-os"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
RDEPEND="
chromeos-base/chromeos-touch-common
sys-apps/etphidiap
!<chromeos-base/touch_updater-0.0.1-r167
"
pkg_preinst() {
enewgroup fwupdate-i2c
enewuser fwupdate-i2c
}
src_install() {
exeinto "/opt/google/touch/scripts"
doexe etphidiap/scripts/*.sh
if [ -d "etphidiap/policies/${ARCH}" ]; then
insinto "/opt/google/touch/policies"
doins etphidiap/policies/"${ARCH}"/*.policy
fi
}