blob: 8609bc91839e7b6121fba69e57d38c301f0b25a5 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("ebe1007d3dc274b2f7eb34cdae12ab7b1de41553" "1ad3e00b6c6e67676d5a1de9689c18bfca31aa1a")
CROS_WORKON_TREE=("487f8c8dfadd10d92f8b7667566bda64d9e36726" "4b2d98b4fa1452c25ee79c4eed04c730712b5bf8")
CROS_WORKON_PROJECT=(
"chromiumos/platform/ec"
"chromiumos/platform/ec"
)
CROS_WORKON_LOCALNAME=(
"platform/ec"
"platform/cr50"
)
CROS_WORKON_DESTDIR=(
"${S}/platform/ec"
"${S}/platform/cr50"
)
CROS_WORKON_EGIT_BRANCH=(
"master"
"cr50_stab"
)
CROS_WORKON_INCREMENTAL_BUILD=1
inherit cros-workon
DESCRIPTION="Exported headers from the embedded controller codebase."
HOMEPAGE="https://www.chromium.org/chromium-os/ec-development"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND=""
DEPEND=""
# No configuration or compilation necessary. This is a header only package.
src_configure() { :; }
src_compile() { :; }
src_install() {
dir_ec=${CROS_WORKON_DESTDIR[0]}
dir_cr50=${CROS_WORKON_DESTDIR[1]}
insinto /usr/include/trunks/cr50_headers/
doins "${dir_cr50}"/include/pinweaver_types.h
doins "${dir_cr50}"/include/u2f.h
doins "${dir_cr50}"/board/cr50/tpm2/virtual_nvmem.h
insinto /usr/include/chromeos/ec/
doins "${dir_ec}"/include/ec_commands.h
doins "${dir_ec}"/util/cros_ec_dev.h
}