blob: 4528cf44cc7801f788522eb307a61ac50fd90518 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5bbbe52a139486abcbd802b9bd3f6763dac479b3"
CROS_WORKON_TREE=("ef118ceb3e8ebcc8b8a4ae6577a71d7ad210a722" "94ae762a180b92279a7a9f0009240f9eaa7f435e" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/container/sdcard .gn"
PLATFORM_SUBDIR="arc/container/sdcard"
inherit cros-workon platform
DESCRIPTION="Container to run Android's sdcard daemon."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/container/sdcard"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="esdfs"
# CONTAINER_DIR must be kept consistent with installation configuration in
# ${PLATFORM_SUBDIR}/BUILD.gn.
CONTAINER_DIR="/opt/google/containers/arc-sdcard"
RDEPEND="!esdfs? ( chromeos-base/arc-setup )"
DEPEND="${DEPEND}"
src_install() {
platform_install
# Keep the parent directory of mountpoints inaccessible from non-root
# users because mountpoints themselves are often world-readable but we
# do not want to expose them.
# container-root is where the root filesystem of the container in which
# arc-obb-mounter daemon runs is mounted.
diropts --mode=0700 --owner=root --group=root
keepdir "${CONTAINER_DIR}"/mountpoints/
keepdir "${CONTAINER_DIR}"/mountpoints/container-root
}