blob: d25be8a90ee97a2d68ac4fe72017cd7ec388f57a [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d24ade58dab8ad0320dc4c61ffa759e11ec287c8"
CROS_WORKON_TREE=("a625767bb59509159091f2ab0b71f8b9b4b2e353" "bea140d13f7cf1092e4c89a45011c04c28327972" "1aed0c3c60315dba4d781aa861490bd01a1d53f6" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-config runtime_probe .gn"
PLATFORM_SUBDIR="runtime_probe"
inherit cros-workon cros-unibuild platform
DESCRIPTION="Device component probe tool **for factory environment**."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/runtime_probe/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="cros-debug +factory_runtime_probe"
# TODO(yhong): Extract common parts with runtime_probe-9999.ebuild to a shared
# eclass.
COMMON_DEPEND="
chromeos-base/chromeos-config-tools:=
"
RDEPEND="
${COMMON_DEPEND}
chromeos-base/ec-utils
"
# Add vboot_reference as build time dependency to read cros_debug status
DEPEND="${COMMON_DEPEND}
chromeos-base/debugd-client:=
chromeos-base/shill-client:=
chromeos-base/system_api:=
chromeos-base/vboot_reference:=
"
pkg_setup() {
cros-workon_pkg_setup
# Assert that the package is not "directly" installed into Chrome OS
# images. We currently only anticipate that files introduced by this
# package being used as the source materials for other packages.
if [[ "$(cros_target)" != "board_sysroot" ]]; then
die "${PN} should never be installed into Chrome OS images directly."
fi
}
src_install() {
platform_install
}