blob: 1498e86d67c1fc5717bbe6f1a077e85532b19bf2 [file] [log] [blame]
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake
DESCRIPTION="Intel Graphics Memory Management Library"
HOMEPAGE="https://github.com/intel/gmmlib"
SRC_URI="https://github.com/intel/gmmlib/archive/intel-${P}.tar.gz"
S="${WORKDIR}/${PN}-intel-${P}"
KEYWORDS="*"
LICENSE="MIT"
SLOT="0/12.1"
IUSE="+custom-cflags test"
RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/${PN}-20.2.2_conditional_testing.patch
"${FILESDIR}"/${PN}-20.3.2_cmake_project.patch
"${FILESDIR}"/${PN}-22.1.1_custom_cflags.patch
"${FILESDIR}"/0001-BACKPORT-Add-RPL-P-DIDs-98.patch
)
src_configure() {
local mycmakeargs=(
-DBUILD_TESTING="$(usex test)"
-DBUILD_TYPE="Release"
-DOVERRIDE_COMPILER_FLAGS="$(usex !custom-cflags)"
)
cmake_src_configure
}