blob: aa86ff575d860bc4f93152fab78717cda69e4099 [file] [log] [blame]
# Copyright 2022 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
# iioservice/ is included just to make sandbox happy when running `gn gen`.
CROS_WORKON_SUBTREE=".gn camera/build camera/features camera/include camera/gpu camera/common camera/mojo chromeos-config common-mk iioservice/libiioservice_ipc iioservice/mojo"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/features/auto_framing/tests"
inherit cros-workon platform
DESCRIPTION="ChromeOS Camera Auto-framing feature tests"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="camera_feature_auto_framing camera_feature_face_detection"
BDEPEND="virtual/pkgconfig"
RDEPEND="
chromeos-base/chromeos-config-tools:=
chromeos-base/cros-camera-android-deps:=
dev-cpp/gtest:=
media-libs/cros-camera-libfs:=
media-libs/libexif:=
media-libs/libsync:=
media-libs/minigbm:=
virtual/opengles:=
x11-libs/libdrm:=
"
DEPEND="
${RDEPEND}
chromeos-base/metrics:=
media-libs/libyuv:=
x11-drivers/opengles-headers:=
"
src_configure() {
cros_optimize_package_for_speed
platform_src_configure
}
src_install() {
dobin "${OUT}"/auto_framing_test
platform_src_install
}