blob: f11d09dc59f3b118ae15f2422e734ba7b0aa6767 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_RUST_REMOVE_DEV_DEPS=1
inherit cros-rust
DESCRIPTION="Parser for Rust source code"
HOMEPAGE="https://crates.io/crates/syn"
SRC_URI="https://crates.io/api/v1/crates/${PN}/${PV}/download -> ${P}.crate"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="${PV}/${PR}"
KEYWORDS="*"
DEPEND="
>=dev-rust/proc-macro2-1.0.26:= <dev-rust/proc-macro2-2
>=dev-rust/quote-1.0:= <dev-rust/quote-2
>=dev-rust/unicode-xid-0.2:= <dev-rust/unicode-xid-0.3
"
RDEPEND="${DEPEND}"
# This file was automatically generated by cargo2ebuild.py
# Changes below are manual:
src_prepare() {
cros-rust_src_prepare
# Delete the test dependency, syn-test-suite.
sed -i '/^test = \[/d' "${S}/Cargo.toml"
}